5 min chart shows 1 minute candles.

0 votes
asked Jun 12, 2017 in AmiBroker by Andy
Hello,

I have issue with chart base time interval. In my database the base interval is 5 min. When I build chart I set intraday view and select the 5 min. But I get 5 min chart where each candle is 1 minute. I have no such issue with 1 hour charts aND other timeframes. Pls advice what to do to fix it.

If you need I can send few screen shots.

1 Answer

0 votes
answered Jun 13, 2017 by anonymous

As always - operator error.

You have wrong settings. You actually have 1-minute data in your DATABASE but you have selected wrong "base time interval"

The setting in File->Database Settings does NOT change actual data. It is just a selector for telling the PLUGINS

what interval to ask from external source. If in your database you ALREADY HAVE 1-minute data, you should

set File->Database Settings, "Base time interval" to 1-minute. This is so because "Base time interval" MUST MATCH ACTUAL DATA that you have. This should be set ONCE per database and never changed.

For changing VIEWING interval use View-> menu.

commented Jun 13, 2017 by Andy
1. No. I have 5 min data base interval.
2. I’m getting data from IB. I set connection according to procedure, which is described on your web-site. From the beginning I set 5 min data base interval.    
For changing VIEWING interval use View-> menu.
I go "View-> menu" and set 5 min chart but as result, I have only last few candles with 5 min size and the rest is 1 min.

I can provide you with screen shots if needed.
commented Jun 15, 2017 by admin (9,260 points)
Now you may have things mixed up. You have to create NEW blank database and set up things correctly as explained above.
Or use "Force backfill" to force all past data. Consult manual for how to do force backfill.
...